Can it be Used with a Macintosh Computer? Pocketrak CX

Last Update: 10/09/2010

The POCKETRAK CX is compatible with Macintosh computers running Mac OS X 10.4 and 10.5

Was this answer helpful?

Thank you for your feedback!

Thank you for the opportunity to serve you. It is possible that we have another article that will address your issue better.
Please click here to see additional articles, or click here to contact our tech support team.

Contact Us

Do you need an additional help?

Return to Top